last.fm for Joomla!-Modul und PHP 5.3+

last.fm for Joomla!-Modul und PHP 5.3+

Das last.fm-Modul for Joomla!, dass Sie hier rechts sehen können, wird leider seit dem 21. November 2009 nicht mehr weiter entwickelt. Will man es auf einer Seite einsetzen, die von PHP 5.3 oder neuer angetrieben wird, erhält man die Fehlermeldung, dass die eingesetzte GD-Bibliothek kein JPEG unterstützen würde. Diese Meldung erscheint auch denn, wenn GD JPEG unterstützt, was daran liegt, dass der Name des entsprechenen Attributs bei der Abfrage der GD-Fähigkeiten in PHP 5.3 geändert wurde. Aus JPG Support wurde JPEG Support.

Will man das Modul nun also auf einen System mit PHP 5.3 einsetzen, muss man zwei Zeichenketten in der Datei helper.php des Moduls ändern. Suchen Sie dort einfach nach JPG Support und ersetzen Sie es durch JPEG Support, und schon läuft das Modul auch mit PHP 5.3 und neuer.


Schreibe einen Kommentar

Ihre E-Mail-Adresse wird nicht veröffentlicht.

You may use these HTML tags and attributes:

<a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <s> <strike> <strong>